Musings of a PC

Thoughts about Windows, TV and technology in general

Getting DCOM errors after installing Windows Server 2003 SP1?

If you get this in the System log on a server after installing SP1:

The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID {BA126AD1-2166-11D1-B1D0-00805FC1270E} to the user NT AUTHORITYNETWORK SERVICE SID (S-1-5-20). This security permission can be modified using the Component Services administrative tool.

then these are the steps you need to take:

  • Go to Adminstrative Tools > Component Services.
  • Drill down Component Services > Computers > My Computer > DCOM Config.
  • Right click on netman and choose Properties.
  • Click on the Security tab.
  • Click on the Edit button within the "Launch and Activation Permission" section.
  • Click on the Add button.
  • Enter Network Service and click on OK.
  • With NETWORK SERVICE still selected in the Launch Permission window, add the Local Activation permission and click on OK.
  • Click on OK to close the netman Properties window.
  • Finally, reboot the server and make sure that the DCOM error doesn’t reoccur.

I’m not quite sure why this is happening but the above is the fix. It looks as if Domain Controllers don’t need the fix.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: